Gigabyte Management Console
User’s Guide
(For ASPEED AST 2400 Chipset)

Version: 1.4
# Table of Contents

Using Your Gigabyte Management Console ................................................................. 3  
Gigabyte Management Console Key Features and Functions ................................. 4  
Software Install ........................................................................................................... 5  
  Prerequisites on remote management PC ................................................................. 5  
  Install Java Tool ........................................................................................................ 5  
  Gigabyte Management Console Network Configuration ................................. 6  
Using the Web UI .......................................................................................................... 8  
Gigabyte Management Console Overview .............................................................. 9  
Enter Gigabyte Management Console ..................................................................... 10  
  Properties .................................................................................................................... 10  
  Configuration ............................................................................................................... 11  
    Network ...................................................................................................................... 11  
  Network Security ......................................................................................................... 12  
  Security ........................................................................................................................ 13  
    Users ........................................................................................................................... 14  
    Services ....................................................................................................................... 15  
    IPMI ............................................................................................................................. 16  
    Time Setting ............................................................................................................... 18  
  Language ....................................................................................................................... 19  
  Sessions .......................................................................................................................... 20  
  LDAP ............................................................................................................................... 21  
  Updates .......................................................................................................................... 22  
  Utilities .......................................................................................................................... 23  
  Server Information ................................................................................................++++  24  
    General Setting ......................................................................................................... 24  
    Power Control ........................................................................................................... 25  
    Power Consumption ................................................................................................ 26  
  System Event Log ......................................................................................................... 27  
  Event Management ....................................................................................................... 28  
    Platform Event .......................................................................................................... 28  
    Trap Settings .............................................................................................................. 29  
    Email Settings .......................................................................................................... 30  
  Serial Over LAN ............................................................................................................ 31  
  vKVM & vMedia .......................................................................................................... 32  
    vKVM Viewer and Virtual Media Session Lanuch ....................................................... 32  
    vKVM & vMedia Configuration .................................................................................. 35  
  System Information ....................................................................................................... 36  
  Processor Information ................................................................................................. 36  
  Memory Device Information ....................................................................................... 37  
  HDD Information ......................................................................................................... 38
Using Your Gigabyte Management Console

The Gigabyte Management Console has a user-friendly Graphics User Interface (GUI) called the Gigabyte Management Console GUI. It is designed to be easy to use. It has a low learning curve because it uses a standard Internet browser. You can expect to be up and running in less than five minutes. This chapter allows you to become familiar with the Gigabyte Management Console GUI’s various functions. Each function is described in detail.
Gigabyte Management Console Key Features and Functions

- Support IPMI v2.0
- Out-of-band monitoring and control for server management over LAN.
- FRU information report includes main board part number, product name, and manufacturer, etc.
- Health status/Hardware monitoring report.
- Events log, view, and clear.
- Event notification via PET (Platform Event Trap).
- Platform Event Filtering (PEF) to take selected action for selected events.
- Chassis management includes power control and status report, front panel buttons and LEDs control.
- Support multi-session user, and alert destination for LAN channel.
Software Install

Prerequisites on remote management PC
Before installing Java tool, please check your system for the following required configuration requirements:

- Supported Browsers:
  - Internet Explorer 8~12
  - Google chrome Version 29.0.1547.66m
  - Firefox 2.0
- JAVA Recommended Version 8 Update 25 or later version (file size: ~ 623KB)

Install Java Tool

Please follow the instruction to install Java in Windows operating system.

1. Go to http://www.java.com
2. Click Download on the middle of the home page.
3. Click on Agree and Start Free Download
4. Click see all Java downloads
5. Select the operating system you are using.
6. Choose the folder location. (Save the file to a known location on your computer)
7. Click Save.
8. Click Yes to replace.
9. Verify that the
   - Name of the file is JavaSetup8u25.exe
   - Size is approximately 623KB.
10. Close all applications including the browser.
11. Double-click on the saved file icon to start the installation process.
Gigabyte Management Console Network Configuration

Please follow the instruction to enable the console redirection function.
1. Go to BIOS setup menu.
2. Select Server Management.
3. Select BMC network Configuration
4. Define Configuration Address source to DynamicBmcDhcp or Static.
5. Save and Exit.
6. The BMC IP Address will appear on the IPv4 Address parameter.
7. Save the configuration and exit BIOS setup menu.
Using the Web UI

The BMC firmware features an embedded web server, enabling users to connect to the BMC using an Internet browser (Microsoft® Internet Explorer™).

The web server shall support 4 concurrent connections

Web-based GUI is supported on the following browsers:

**Microsoft Windows:**

- Internet Explorer 8 ~ 12
- Mozilla® Firefox® 2.0 or later

**Linux:**

Mozilla Firefox 2.0 or later
1. Open a web browser and type in your identified IP. The IP address can be found using your DHCP server.
2. A dialog box prompts you to enter Username and Password.
3. Enter the following values:
   Username: admin
   Password: password

⚠️ If your motherboard is Intel C20x series chipset, please enter the following values:
   Username: root
   Password: superuser

⚠️ The default user name and password are in lower-case characters.

⚠️ When you log in using the root user name and password, you have full administrative powers. It is advised that once you log in, you change the root password.
Enter Gigabyte Management Console

After you successfully log into your Gigabyte Management Console, the Remote Management Console GUI appears.

Properties

Properties displays the firmware version of current remote client system.
Configuration
Network
You can view and modify the network settings on this screen. Select the Network Mode from the drop-down list.

1. **Dedicate Mode**
When set to Dedicate Mode, you can configure the BMC related settings through the BMC port.

2. **Shared Mode**
When set to Shared Mode, you can configure the BMC related settings through the NIC2 port. (Shared NIC Mode)

3. **Failover Mode**
When set to Failover Mode, you can configure the BMC related settings through the BMC or NIC2 port. (Backup Mode)

When you finish configuration, click **Apply Change**.

Please note that the changes may not take effect immediately, click "Refresh" to take effect of changes.
Network Security
You can configure the network security settings on this screen. Check the **IP Blocking Enabled** box and input the desire value of **IP Blocking Fail Count**, **IP Blocking Fail Window**, and **IP Blocking Penalty Time**. After you finish the configuration, click **Apply Change** to save the settings.
Security

The Security page shows the current certificate status.

To generate a new certificate, click **Generate Certificate**.

To upload a certificate, click **Upload Certificate**.
Users
To configure a specific user, click the Users ID. To display new user information, click Refresh.

NOTE: BMC convention for enabling an ‘anonymous’ login is to configure the entry for User ID 1 with a null username (all zero’s) and a null password (all zero’s). Applications may then present this to the user as an anonymous login.
Services
You can configure the web server parameters (such as, HTTP Port Number, HTTPS Port Number, and Timeout) on a remote computer. By default, the timeout is 1800 seconds.
When you finish the configuration, click Apply Changes.
IPMI
This screen contains two sections: IPMI Serial and IPMI Settings.

IPMI Serial
There are four serial configuration in IPMI Serial: Connection Mode Settings, Baud Rate, Flow Control, and Channel Privilege Level Limit.

The Connection Mode Settings allows user to select the Console redirection type and to manage the system from a remote location.
Once the connection mode is set, select the Baud Rate and Flow Control from the drop-down list.

With Channel Privilege Level Limit, users can be configured to operate with a particular maximum Privilege Level. Privilege levels tell the BMC which commands are allowed to be executed. The following table shows the Channel Privilege Level.

<table>
<thead>
<tr>
<th>Users</th>
<th>This may be considered the lowest privilege level.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Operator</td>
<td>All BMC commands are allowed, except for configuration commands that can change the behavior of the out-of-band interfaces. For example, Operator privilege does not allow the capability to disable individual channels, or change user access privileges.</td>
</tr>
<tr>
<td>Administrator</td>
<td>All BMC commands are allowed, including configuration commands. An Administrator can even execute configuration commands that would disable the channel that the Administrator is communicating over.</td>
</tr>
</tbody>
</table>
**IPMI Settings**

IPMI Settings provides remote configuration over LAN. To activate IPMI remote configuration by LAN, check Enable IPMI Over LAN option, define the Channel Privilege Level Limit, and enter the Encryption Key.

When you finish the configuration, click “Apply Changes”.
**Time Setting**
This page provides the mechanism to configure the Network Time acquisition method. With Administrator or Operator privilege level, you can modify configuration settings and click the Apply Changes button to execute the settings, as well as click the Sync Time Now button (when in Requested Mode) to request an immediate clock set.

**Operation Mode**
Configures the NTP Mode. You can Disable NTP, set Requested Mode, or Daemon Mode in this parameter.
In Requested Mode, you can request an immediate clock synchronization with the NTP server; request will be sent when click the Sync Time Now button.
The Daemon Mode runs NTP daemon which sends a NTP request at approximately 5 minute intervals. Multiple NTP servers may be specified to provide redundancy.

**Time Synchronization Method**
Specifies the synchronization method for Requested Mode. Select Slew mode when you want to adjust the time smoothly over time if there are time sensitive applications in place. Select Step mode to aggressively change the time using settimeofday() system call.
Language

This page allows users to choose preferred language when using the WebUI. When you finish the configuration, click “Apply Changes”.

Language

This page provides the language display setting for WebGUI, Virtual KVM Viewer, and Virtual Media Session.

Language

English
Sessions

This screen displays information on Active Sessions. Additionally, the trash can icon provides the delete function for privileged users. Click **Refresh** to refresh the Sessions status.

### Sessions

Use this page to view information about the active sessions. Additionally, privileged users can click on the trash can icon to kill an active session.

<table>
<thead>
<tr>
<th>Session ID</th>
<th>User Name</th>
<th>IP Address</th>
<th>Session Type</th>
<th>Kill</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>john</td>
<td>1.1.1.1</td>
<td>CEO</td>
<td>No</td>
</tr>
</tbody>
</table>
LDAP

LDAP screen allows download user list of LDAP server then create Gigabyte Management Console user account from this list directly.

Check the box below to enable LDAP authentication and enter the required information to access the LDAP server. Click **Apply Changes** to save your changes.
**Updates**

The firmware can be updated remotely.

To update firmware, follow the instruction below:

1. Select Update Type.
2. Select the file on your local system by using **Browse**.

Click **Upload** to update to the new version of firmware.
Utilities
Utilities provides BMC reboot and Factory default restore functions.

1. To reboot system, click **Reboot**.
2. To restore factory default, click **Factory Default**.
3. To set **Fan Threshold**, enter **Probe Name**, **Lower Non-Critical**, **Lower Critical value**, and click **Submit**.
4. To Adjust the PWM offset for the system fans, enter offset values and click **Submit**.
5. To update Logo, select the file on your local system using **Browse** and click **Update**.
Server Information
General Setting
This page displays a real-time record of the system health related information such as Voltage, Power Supplies, Fans and Temperatures. Define **Auto Refresh Interval** and **Sensor Type** from the drop-down list, and select **Display Type**. Click **Refresh** to update current health status for Voltage, Power Supplies, Fans and Temperatures.
Power Control

The Power Control allows you to power on/off/cycle the remote host system. Additionally, you can see the remote power status.

To perform the power control operation, select the operation and click **Apply Changes**.
Power Consumption
This section allows user to configure the power policies for the system.

Power Limit
Check **Power Limit Management Activated** box and input the desired value in the respective columns.

When you finish the configuration, click **Apply Changes**.
System Event Log

It records the event when sensor has an abnormal state. When the log matches the pre-defined alert, the system sends out the notification automatically, if it is pre-configured.
**Event Management**

**Platform Event**

A platform event filter (PEF) can trigger an action and generate an alert when a critical hardware-related event occurs. For each PEF, you can choose the action to be taken when a platform event occurs.

You can also choose to generate and send an alert when a platform event occurs. In the Platform Events screen, you can enable the generation of platform event alerts globally by clicking Global Alerting Enable.

When you finish the configuration, click **Apply Changes**.
Trap Settings

In the Trap Settings, user can set the IPv4 and IPv6 Destination List. IPv6 and IPv4 are two completely separate protocols. IPv6 is not backwards compatible with IPv4, and IPv4 hosts and routers will not be able to deal directly with IPv6 traffic. IPv6 has a significantly larger address space than IPv4. This results from the use of a 128-bit address, whereas IPv4 uses only 32 bits.

When you finish the configuration, click **Apply Changes**.

Before sending trap, please make sure changes to the target Destination and Community String have been saved by clicking Apply Changes.

IPv4 Destination List

<table>
<thead>
<tr>
<th>Enable</th>
<th>IPv4 Address</th>
<th>Text</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>0.0.0.1</td>
<td></td>
</tr>
<tr>
<td></td>
<td>0.0.0.4</td>
<td></td>
</tr>
<tr>
<td></td>
<td>0.0.0.8</td>
<td></td>
</tr>
<tr>
<td></td>
<td>0.0.0.16</td>
<td></td>
</tr>
</tbody>
</table>

IPv6 Destination List

<table>
<thead>
<tr>
<th>Enable</th>
<th>IPv6 Address</th>
<th>Text</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>0.0.0.1</td>
<td></td>
</tr>
<tr>
<td></td>
<td>0.0.0.4</td>
<td></td>
</tr>
<tr>
<td></td>
<td>0.0.0.8</td>
<td></td>
</tr>
<tr>
<td></td>
<td>0.0.0.16</td>
<td></td>
</tr>
</tbody>
</table>

Community String

<table>
<thead>
<tr>
<th>Community Name</th>
<th></th>
</tr>
</thead>
</table>
Email Settings
If you want the alert to be sent by email, you can configure to specify the e-mail address, subject and message in the Email Settings. After you finish the configuration, click Apply Change to save the settings.

SMTP
Set E-mail (SMTP) server IP address for sending alert notification to user.
Check the SMTP Authentication Enabled box and enter the SMTP IP address, User Name, Password; select the STARTTLS Mode and SASL Mode from the drop-down list.
When you finish the configuration, click “Apply Changes”.

Serial Over LAN

You can configure the Serial Over LAN settings on this screen. Check the Enable Serial Over LAN box and select the Baud Rate and Channel Privilege Limit from the drop-down list. After you finish the configuration, click Apply Change to save the settings.
vKVM & vMedia

vKVM Viewer and Virtual Media Session Launch

This screen allows you to start a Remote Console session with the host system.
Launch Java KVM Viewer
Click Launch Java KVM Viewer to launch the redirection console and manage the server remotely. After clicking the button, a console appears as below:

For KVM and remote redirection detail function description, please go to chapter:
KVM Function Description
Launch Java VM Client
Click **Launch Java VM Client** to launch the redirection console and manage the local computer.

After clicking the button, a console appears as below:

![Console Image](image)

<table>
<thead>
<tr>
<th>Function Item</th>
<th>Resulting Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mapped</td>
<td>Check the mapped box next to the drive types you want to connect.</td>
</tr>
<tr>
<td>Create Image…</td>
<td>Click the <strong>Create Image</strong>…button and create to the image.</td>
</tr>
<tr>
<td>Add Image…</td>
<td>Click the <strong>Add Image</strong>…button and browse to the image.</td>
</tr>
<tr>
<td>Remove Image</td>
<td>Click the <strong>Remove Image</strong>…button and remove to the image.</td>
</tr>
<tr>
<td>Exit</td>
<td>Click <strong>Exit</strong> button to terminate the Media Redirection wizard.</td>
</tr>
<tr>
<td>Details</td>
<td>Click <strong>Details</strong> to see more information of the image.</td>
</tr>
<tr>
<td>USB Reset</td>
<td>Click <strong>USB Reset</strong> to reset the USB.</td>
</tr>
</tbody>
</table>
vKVM & vMedia Configuration
This screen allows you to configure the Remote Console settings. Check the Virtual KVM Configuration Enabled box or Virtual Media Configuration Enabled box, and select the Max Sessions, Remote Port, Video Encryption Enabled, and Preference Client from the drop-down list. After you finish the configuration, click “Apply Change” to save the settings.
System Information

Processor Information

This page displays the technical specifications of the installed processor.

Processor Information

<table>
<thead>
<tr>
<th>Socket</th>
<th>SOCKET E</th>
</tr>
</thead>
<tbody>
<tr>
<td>Vendor</td>
<td>Intel</td>
</tr>
<tr>
<td>Model</td>
<td>CPU E5-2650 v3 @ 2.30GHz</td>
</tr>
<tr>
<td>Core Count</td>
<td>10</td>
</tr>
<tr>
<td>Package</td>
<td>BAD OFFSET</td>
</tr>
<tr>
<td>Manufacturer</td>
<td>BAD OFFSET</td>
</tr>
<tr>
<td>Version</td>
<td>BAD Offset</td>
</tr>
<tr>
<td>Max Speed</td>
<td>2000 MHz</td>
</tr>
<tr>
<td>Core Count</td>
<td>10</td>
</tr>
</tbody>
</table>

GIGABYTE™ Embedded Management Software
Memory Device Information

This page displays the technical specifications of the installed memory.

<table>
<thead>
<tr>
<th>Slot (Device Locator)</th>
<th>Manufacturer</th>
<th>Size</th>
<th>Speed</th>
<th>Type</th>
<th>Serial Number</th>
<th>Part Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>BAD OFFSET</td>
<td>BAD OFFSET</td>
<td>0 MB</td>
<td>0 MHz</td>
<td>NULL</td>
<td>BAD OFFSET</td>
<td>BAD OFFSET</td>
</tr>
<tr>
<td>BAD OFFSET</td>
<td>BAD OFFSET</td>
<td>0 MB</td>
<td>0 MHz</td>
<td>NULL</td>
<td>BAD OFFSET</td>
<td>BAD OFFSET</td>
</tr>
<tr>
<td>BAD OFFSET</td>
<td>BAD OFFSET</td>
<td>0 MB</td>
<td>0 MHz</td>
<td>NULL</td>
<td>BAD OFFSET</td>
<td>BAD OFFSET</td>
</tr>
<tr>
<td>BAD OFFSET</td>
<td>BAD OFFSET</td>
<td>0 MB</td>
<td>0 MHz</td>
<td>NULL</td>
<td>BAD OFFSET</td>
<td>BAD OFFSET</td>
</tr>
<tr>
<td>NOT SPECIFIED</td>
<td>BAD INDEX</td>
<td>128 MB</td>
<td>2000 MHz</td>
<td>NULL</td>
<td>BAD INDEX</td>
<td>BAD INDEX</td>
</tr>
<tr>
<td>BAD OFFSET</td>
<td>BAD OFFSET</td>
<td>0 MB</td>
<td>0 MHz</td>
<td>NULL</td>
<td>BAD OFFSET</td>
<td>BAD OFFSET</td>
</tr>
<tr>
<td>BAD OFFSET</td>
<td>BAD OFFSET</td>
<td>0 MB</td>
<td>0 MHz</td>
<td>NULL</td>
<td>BAD OFFSET</td>
<td>BAD OFFSET</td>
</tr>
<tr>
<td>BAD OFFSET</td>
<td>BAD OFFSET</td>
<td>0 MB</td>
<td>0 MHz</td>
<td>NULL</td>
<td>BAD OFFSET</td>
<td>BAD OFFSET</td>
</tr>
<tr>
<td>BAD OFFSET</td>
<td>BAD OFFSET</td>
<td>0 MB</td>
<td>0 MHz</td>
<td>NULL</td>
<td>BAD OFFSET</td>
<td>BAD OFFSET</td>
</tr>
<tr>
<td>NOT SPECIFIED</td>
<td>BAD INDEX</td>
<td>128 MB</td>
<td>2000 MHz</td>
<td>NULL</td>
<td>BAD INDEX</td>
<td>BAD INDEX</td>
</tr>
<tr>
<td>BAD OFFSET</td>
<td>BAD OFFSET</td>
<td>0 MB</td>
<td>0 MHz</td>
<td>NULL</td>
<td>BAD OFFSET</td>
<td>BAD OFFSET</td>
</tr>
<tr>
<td>BAD OFFSET</td>
<td>BAD OFFSET</td>
<td>0 MB</td>
<td>0 MHz</td>
<td>NULL</td>
<td>BAD OFFSET</td>
<td>BAD OFFSET</td>
</tr>
<tr>
<td>BAD OFFSET</td>
<td>BAD OFFSET</td>
<td>0 MB</td>
<td>0 MHz</td>
<td>NULL</td>
<td>BAD OFFSET</td>
<td>BAD OFFSET</td>
</tr>
<tr>
<td>BAD OFFSET</td>
<td>BAD OFFSET</td>
<td>0 MB</td>
<td>0 MHz</td>
<td>NULL</td>
<td>BAD OFFSET</td>
<td>BAD OFFSET</td>
</tr>
<tr>
<td>BAD OFFSET</td>
<td>BAD OFFSET</td>
<td>0 MB</td>
<td>0 MHz</td>
<td>NULL</td>
<td>BAD OFFSET</td>
<td>BAD OFFSET</td>
</tr>
<tr>
<td>BAD OFFSET</td>
<td>BAD OFFSET</td>
<td>0 MB</td>
<td>0 MHz</td>
<td>NULL</td>
<td>BAD OFFSET</td>
<td>BAD OFFSET</td>
</tr>
<tr>
<td>BAD OFFSET</td>
<td>BAD OFFSET</td>
<td>0 MB</td>
<td>0 MHz</td>
<td>NULL</td>
<td>BAD OFFSET</td>
<td>BAD OFFSET</td>
</tr>
<tr>
<td>BAD OFFSET</td>
<td>BAD OFFSET</td>
<td>0 MB</td>
<td>0 MHz</td>
<td>NULL</td>
<td>BAD OFFSET</td>
<td>BAD OFFSET</td>
</tr>
<tr>
<td>BAD OFFSET</td>
<td>BAD OFFSET</td>
<td>0 MB</td>
<td>0 MHz</td>
<td>NULL</td>
<td>BAD OFFSET</td>
<td>BAD OFFSET</td>
</tr>
</tbody>
</table>
HDD Information
This page displays the connected hard disk drive and hardware health information.

<table>
<thead>
<tr>
<th>Port Number</th>
<th>Device Name</th>
<th>Device Size</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>ADATA SX1000L</td>
<td>100 GB</td>
</tr>
<tr>
<td>1</td>
<td>ADATA SX1000L</td>
<td>100 GB</td>
</tr>
<tr>
<td>2</td>
<td>ADATA SX1000L</td>
<td>100 GB</td>
</tr>
<tr>
<td>3</td>
<td>NO HD</td>
<td>0 GB</td>
</tr>
<tr>
<td>4</td>
<td>NO HD</td>
<td>0 GB</td>
</tr>
</tbody>
</table>

sSATA Device

<table>
<thead>
<tr>
<th>Port Number</th>
<th>Device Name</th>
<th>Device Size</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>NO HD</td>
<td>0 GB</td>
</tr>
<tr>
<td>1</td>
<td>NO HD</td>
<td>0 GB</td>
</tr>
<tr>
<td>2</td>
<td>NO HD</td>
<td>0 GB</td>
</tr>
</tbody>
</table>

Support Help About Logout
Welcome admin [Administrateur] Wed Nov 4 2:01:14 (GMT+08:00)
KVM Function Description

After selecting KVM Remote Console Redirection button, system will lead you to the main menu of KVM window which is shown as below:

![KVM Window](image)

### Main Menu

The items in the main menu will be described in the following sections.

### File

<table>
<thead>
<tr>
<th>Menu Item</th>
<th>Resulting Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>File→Capture to File</td>
<td>Save a snapshot of the target’s desktop to a file.</td>
</tr>
<tr>
<td>File→Exit</td>
<td>Terminate the KVM session and close.</td>
</tr>
</tbody>
</table>
### View

<table>
<thead>
<tr>
<th>Menu Item</th>
<th>Resulting Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>View → Hide/Show Status Bar</td>
<td>Hide / Show the status bar which includes &quot;Session IP address&quot;, &quot;Session Username&quot;, &quot;Frame Rate&quot;, and &quot;Bandwidth&quot;.</td>
</tr>
<tr>
<td>View → Refresh</td>
<td>Sends a request to the KVM server asking for a reference screen.</td>
</tr>
<tr>
<td>View → Full Screen</td>
<td>Will switch to full screen mode. This menu is only available when not in full screen mode.</td>
</tr>
<tr>
<td>View → Fit</td>
<td>Resized the window to the size needed to completely display the targets desktop without an extra border or scrollbars. This will only work if the client desktop is large enough to accommodate the resized window.</td>
</tr>
</tbody>
</table>
**Marcos**

Macros are a mechanism to send keystrokes to the target that the user may otherwise not be able to send. One of the most obvious examples of this is the Ctrl-Alt-Del sequence under Windows. Because this sequence of keystrokes is intercepted by the Windows OS, the KVM client will never receive the complete sequence and can therefore never send them to the target through normal keyboard operation. The solution to this is to provide an alternate mechanism for generating these keystrokes. We refer to these keystroke sequences as macros.

The list of supported macros is as follows:

<table>
<thead>
<tr>
<th>Menu Item</th>
<th>Resulting Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tools → Instant Messaging</td>
<td>This will bring up the instant message.</td>
</tr>
<tr>
<td>Tools → Session Options</td>
<td>This will bring up the session options dialog. The session options provide the configuration of <strong>Keyboard pass through mode</strong>, <strong>Mouse</strong>, and <strong>Video Quality</strong>.</td>
</tr>
<tr>
<td>Tools → Session User List</td>
<td>This will display all shared KVM users name.</td>
</tr>
<tr>
<td>Tools → Single Cursor</td>
<td>Causes the viewer to enter single cursor mode.</td>
</tr>
<tr>
<td>Tools → Stats</td>
<td>Will display the performance statistics dialog.</td>
</tr>
</tbody>
</table>
### Power

<table>
<thead>
<tr>
<th>Menu Item</th>
<th>Resulting Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Power → Power On System</td>
<td>Turns the power on.</td>
</tr>
<tr>
<td>Power → Power Off System</td>
<td>Turns the power off.</td>
</tr>
<tr>
<td>Power → Graceful Shutdown</td>
<td>Issue a graceful shutdown command to the target.</td>
</tr>
<tr>
<td>Power → Reset System (warm boot)</td>
<td>Issues a reboot command to the target. Target will reboot without powering off.</td>
</tr>
<tr>
<td>Power → Power Cycle System (cold boot)</td>
<td>This will power cycle the target by turning the power off for a short period of time and then back on again.</td>
</tr>
</tbody>
</table>

### Help

<table>
<thead>
<tr>
<th>Menu Item</th>
<th>Resulting Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Help → Contents and Index</td>
<td>Will cause the viewer help to be displayed.</td>
</tr>
<tr>
<td>Help → About</td>
<td>Will display a dialog with the product name, version, and copyright notices.</td>
</tr>
</tbody>
</table>